Friday, December 25, 2020

How to apply language patches after the main patch has been applied EBS r12.2

1- Apply main patch using below command.


time adop phase=apply patches=31625670 


2- To apply language patches.


time adop phase=apply patches=31625670_D:u31625670.drv,31625670_DK:u31625670.drv,31625670_ESA:u31625670.drv,31625670_F:u31625670.drv,31625670_I:u31625670.drv,31625670_NL:u31625670.drv,31625670_ZHS:u31625670.drv,31625670_ZHT:u31625670.drv  workers=16 wait_on_failed_job=yes flags=autoskip

Presentation Catalog Permission Behavior When Same EBS User Logs Into OBIEE Using Different Responsibilities Back And Forth

What happens is the following:

  • User selects a responsibility '<respA>' in EBS, which is mapped to an OBIEE Application Role '<respA>' and is logged in to OBIEE with SSO. The user gets the '<respA>' Application Role in OBIEE
  • User logs off using the 'Sign Out' link which returns the user back to EBS
  • User selects a different responsibility, '<respB>', but after login to OBIEE the Application Role of the previous session remains active '<respA>', instead of using the new application role '<respB>'


Disable connection pooling:

1- For each Connection Pool in the OBIEE rpd (repository) file, uncheck the "Enable connection pooling" option.


Disable connection pooling

2- Save the rpd and distribute it to the server.

 

Tuesday, December 15, 2020

ADOP fails with [ERROR] ETCC not run in the database node DBHOSTNAME in R12.2

 Error:-


1- adop phase=prepare.

[ERROR]     ETCC not run in the database node prerptdb01
                The EBS Technology Codelevel Checker needs to be run on the database node.
                It is available as Patch 17537119.
    Encountered the above errors when performing database validations.
    Resolve the above errors and restart adop 


Solution:-


1- It might be due to mismatch in host name between APPS.FND_NODES and APPLSYS.TXK_TCC_RESULTS tables.

2-  Take backup of APPLSYS.TXK_TCC_RESULTS

create table APPS.TXK_TCC_RESULTS_backup as select * from APPLSYS.TXK_TCC_RESULTS;

3- Truncate APPLSYS.TXK_TCC_RESULTS table.

truncate table  APPLSYS.TXK_TCC_RESULTS

4-  UPDATE applsys.txk_tcc_results SET node_name ='<node name>';

Wednesday, December 9, 2020

Upgrade to Oracle Database 19c from 12c using autoupgrade

 1- Download the most recent version from MOS Note: 2485457.1 – AutoUpgrade Tool.

2- Create sample Auto-Upgrade config file.

java -jar $OH19/rdbms/admin/autoupgrade.jar -create_sample_file config

3- Edit Sample file.

[oracle@dbinstance ~]$ vi sample_config.cfg
[oracle@dbinstance ~]$ vi sample_config.cfg
[oracle@dbinstance ~]$ more sample_config.cfg
# $Header: rdbms/src/server/upgrade/autoupgrade/src/main/resources/autoupgrade/templates/sample_config_unix.properties /st_rdbms_pt-autoupgrade/7 2018/07/11 09:38:
27 frealvar Exp $
#
# Copyright (c) 2017, 2018, Oracle and/or its affiliates.
# All rights reserved.*/
#
#
# DESCRIPTION
# This is a template for config file to be used with autoupgrade tool.
#
# NOTES
# <other useful comments, qualifications, etc.>
#
# MODIFIED    (MM/DD/YY)
# frealvar    07/10/18 - code refactor due to AUPG-250
# frealvar    04/30/18 - AUPG-189 optionally run utlrp and timezone upgrades
# fvallin     04/06/17 - Creation
#
#
#Global configurations
#Autoupgrade's global directory, non-job logs generated,
#temp files created and other autoupgrade files will be
#send here
global.autoupg_log_dir=/home/oracle/upgrade_logs

#
# sample config file
#
#
 Database number 1
#
upg1.dbname=PROD
upg1.start_time=NOW
upg1.source_home=/u02/app/oracle/product/12.1.0/dbhome_1
upg1.target_home=/u01/app/oracle/product/12.1.0/dbhome_1
upg1.sid=PROD
upg1.log_dir=/home/oracle/logs
upg1.upgrade_node=localhost
upg1.target_version=19.3
#upg1.run_utlrp=yes
#upg1.timezone_upg=yes
#

4- Make one directory called upgrade_logs and logs which will hold all the config files, log files during this upgrade.

[oracle@dbinstance ~]$ mkdir -p /home/oracle/upgrade_logs
[oracle@dbinstance ~]$ mkdir -p /home/oracle/logs
[oracle@dbinstance ~]$ cp sample_config.cfg UPGR.cfg

5- Running AutoUpgrade.jar

ANALYZE mode.

[oracle@dbinstance ~]$ java -jar $ORACLE_HOME/rdbms/admin/autoupgrade.jar -config /home/oracle/UPGR.cfg -mode analyze
Autoupgrade tool launched with default options
+--------------------------------+
| Starting AutoUpgrade execution |
+--------------------------------+
1 databases will be analyzed
Enter some command, type 'help' or 'exit' to quit
upg> lsj
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
|JOB#|DB NAME|    STAGE|OPERATION| STATUS|    START TIME|END TIME| UPDATED|       MESSAGE|
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
| 100|   PROD|PRECHECKS|PREPARING|RUNNING|20/05/18 15:11|     N/A|15:11:09|Remaining 0/75|
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
Total jobs 1
upg>
Job 100 for PROD FINISHED
[oracle@dbinstance ~]$

upg> status -job 102

Progress

-----------------------------------

Start time:      20/05/18 15:13

Elapsed (min):   122

End time:        N/A

Last update:     2020-05-18T17:15:05.211

Stage:           POSTFIXUPS

Operation:       EXECUTING

Status:          RUNNING

Pending stages:  2


Job Logs Locations

-----------------------------------

Logs Base:    /home/oracle/logs

Job logs:     /home/oracle/logs/102

Stage logs:   /home/oracle/logs/102/postfixups

TimeZone:     /home/oracle/logs/temp


Additional information

-----------------------------------

Details:

Starting FIXUPS execution

Error Details:

None

upg>

Job 102 for PROD FINISHED

[oracle@dbinstance ~]$


6- Check below html file under /home/oracle/upgrade_logs and fix the errors.

autoupgrade logs


7- Deploy mode.


[oracle@dbinstance ~]$ java -jar $ORACLE_HOME/rdbms/admin/autoupgrade.jar -config /home/oracle/UPGR.cfg -mode deploy
Previous execution found
loading latest data
Total jobs recovered: 1
+--------------------------------+
| Starting AutoUpgrade execution |
+--------------------------------+
Enter some command, type 'help' or 'exit' to quit
upg> lsj
+----+-------+---------+---------+-------+--------------+--------+--------+-------+
|JOB#|DB NAME|    STAGE|OPERATION| STATUS|    START TIME|END TIME| UPDATED|MESSAGE|
+----+-------+---------+---------+-------+--------------+--------+--------+-------+
| 102|   PROD|PRECHECKS|PREPARING|RUNNING|20/05/18 15:13|     N/A|16:12:07|       |
+----+-------+---------+---------+-------+--------------+--------+--------+-------+
Total jobs 1
upg> lsj
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
|JOB#|DB NAME|    STAGE|OPERATION| STATUS|    START TIME|END TIME| UPDATED|       MESSAGE|
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
| 102|   PROD|PRECHECKS|PREPARING|RUNNING|20/05/18 15:13|     N/A|16:12:14|Remaining 1/75|
+----+-------+---------+---------+-------+--------------+--------+--------+--------------+
Total jobs 1
upg> lsj

upg> lsj
+----+-------+---------+---------+-------+--------------+--------+--------+-----------+
|JOB#|DB NAME|    STAGE|OPERATION| STATUS|    START TIME|END TIME| UPDATED|    MESSAGE|
+----+-------+---------+---------+-------+--------------+--------+--------+-----------+
| 102|   PROD|DBUPGRADE|EXECUTING|RUNNING|20/05/18 15:13|     N/A|16:35:28|0%Upgraded |
+----+-------+---------+---------+-------+--------------+--------+--------+-----------+
Total jobs 1
upg> status
---------------- Config -------------------
User configuration file    [/home/oracle/UPGR.cfg]
General logs location      [/home/oracle/upgrade_logs/cfgtoollogs/upgrade/auto]
Mode                       [DEPLOY]
DB upg fatal errors        ORA-00600,ORA-07445
DB Post upgrade abort time [60] minutes
DB upg abort time          [1440] minutes
DB restore abort time      [120] minutes
DB drop GRP abort time     [3] minutes
------------------- Jobs -------------------
Total databases in configuration file [1]
Total Non-CDB being processed         [1]
Total CDB being processed             [0]
Jobs finished successfully            [0]
Jobs finished/aborted                 [0]
jobs in progress                      [1]
------------ Resources ----------------
Threads in use                        [62]
JVM used memory                       [105] MB
CPU in use                            [13%]
Processes in use                      [18]

8- Completion Message.

upg>
Job 102 for PROD FINISHED


9- Check the database version

[oracle@dbinstance ~]$ export ORACLE_SID=PROD
[oracle@dbinstance ~]$ sqlplus / as sysdba

SQL*Plus: Release 19.0.0.0.0 - Production on Mon May 18 17:43:37 2020
Version 19.3.0.0.0

Copyright (c) 1982, 2019, Oracle.  All rights reserved.


Connected to:
Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production
Version 19.3.0.0.0

 select name from v$database;

NAME
---------
PROD






Featured post

Migrate OCR & vote from external to normal or High redundancy in ASM

How to Move OCR & Vote from external to Normal or high. 1)  Create New diskgroup(CRS) with suitable redundancy for OCR and Voting files....

Popular Posts